Cara membuat PPPoE server di MikroTik

Cara membuat PPPoE server di MikroTik

loading....

Pada artikel kali ini saya akan membuat tentang pppoe server di mikrotik dengan dan bandwidth management dengan cara menggunakan queue tree.

Untuk membuat PPPoE server dapat dilakukan dengan cara masuk ke menu PPP lalu lakukanlah langkah langkah berikut :

  1. Buatlah pppoe server dengan mengklik tombol ( + ) pada tab PPPoE Server kemudian berilah nama pada service dan isikan interface yang akan digunakan sebagai pppoe server. dan untuk konfigurasi yang lain nya sesuaikan saja sesuai dengan gambar. dan untuk bagian time out teman teman dapat merubah angkanya tapi perlu di perhatikan time out ini harus tetap ada
  2. Buatlah Profile baru pada tab profile dengan mengklik tombol ( + ) lalu pada tab general isikan name sesuai selera teman teman dan pada local address isikan ip address yang akan menjadi ip dari ppoe server teman teman
  3. lalu masuk ke tab scripts dan masukan script di bawah ini
    On Up :
    :delay 2;
    :local ip [/ip address get [/ip address find interface="<pppoe-$user>"] network]; 
    /ip firewall mangle add chain=prerouting comment="pppoe-$user" src-address=$ip in-interface="<pppoe-$user>" action="mark-connection" new-connection-mark="c-pppoe-$user"
    /ip firewall mangle add chain=forward comment="pppoe-$user" connection-mark="c-pppoe-$user" action="mark-packet" new-packet-mark="p-pppoe-$user" passthrough=no
    :delay 1;
    /queue tree add name="$user-PPPOE-D" packet-mark="p-pppoe-$user" max-limit="1M" parent="<pppoe-$user>";
    /queue tree add name="$user-PPPOE-U" packet-mark="p-pppoe-$user" max-limit="1M" parent="ether1-wan";

    On Down :

    :delay 1;
    /ip firewall mangle remove [find where comment="pppoe-$user"];
    :delay 1;
    /queue tree remove [find name="$user-PPPOE-D"]; 
    /queue tree remove [find name="$user-PPPOE-U"];
  4. sekarang masuklah ke tab secrets dan buat lah user di sini . Masukan lah username yang di inginkan beserta passwordnya dan jangan lupa tentukan ip address untuk user yang teman teman buat

dengan setingan di atas teman teman telah berhasil membuat pppoe server dengan limit upload dan download nya 4 mbps. Penentuan bandwith management terletak pada script nya di letakan di profile.

Simak video Cara membuat PPPoE server di MikroTik
Artikel Menarik Lainnya
mikrotik pppoe server, mikrotik pppoe bandwidth management, mikrotik pppoe server setup, mikrotik pppoe simple queue

loading...