Memblokir sebuah situs dengan firewall mikrotik

Memblokir sebuah situs dengan firewall mikrotik

loading....

Masih bertema tentang firewall dan mikrotik kali ini rumah code akan membahas bagaimana caranya membokir situs web dengan firewall mikrotik. Situs yang akan saya gunakan sebagai contoh untuk situs yang di blokir adalah facebook,instagram dan youtube.

Baca Juga : Mengenal apa yang dimaksud dengan firewall

Untuk memblokir sosial media di mikrotik seperti facebook dan instagram kita dapat menggunakan layer 7 protocols sedangkan untuk memblokir youtube saya belum menemukan cara yang pass dan tepat oleh karena itu saya akan memblokir youtube dengan cara memblokir IP address googlevideo.com beserta sub domain nya.

Blokir instagram

Untuk memblokir instagram di mikrotik dengan cara menggunakan layer 7 protocols kita cukup membuat rule pada menu IP > Firewall tab layer 7 Protocols dan isi lah regexp dengan perintah berikut

^.+(instagram.com).*$

Blokir Facebook

Cara memblokir facebook dengan mikrotik juga dapat dilakukan dengan menggunakan layer 7 protocols. Tahapan untuk membuat rule pada layer 7 protocols sama dengan cara memblokir instagram cuman pada bagian regexp saja yang berbeda

^.+(facebook.com).*$

setelah kita membuat kedua rule di atas kita tinggal membuat rule pada IP > Firewall tab filter rules untuk memblokir nya. Untuk teman teman yang belum tau caranya teman teman dapat melihat artikel saya sebelumnya dengan judul Konfigurasi firewall pada mikrotik.

Blokir Youtube

Untuk memblokir youtube di mikrotik saya tidak akan menggunakan layer 7 protocols. karena saya belum menemukan formula yang tepat untuk melakukanya. Jadi saya akan memblokir ip address nya saja. Pada tutorila kali ini saya tidak akan memblokir situs youtube.com kareuna itu tidak akan efektif untuk memblokir youtube di smartphone jadi saya akan memblokir tempat dimana video itu di simpan yaitu di googlevideo.com. Nah sekarang kita perlu mendapatkan IP address dari subdomain googlevideo.com dengan cara menggunakan nslookup di cmd atau kamu juga dapat menggunakan nslookup online.

Untuk mendapatkan ip address dari google video kamu cukup membuka youtube dan menyetel video nya kemudian pada keyboard tekan tombol Ctrl + Shift + i kemudian masuk ke tab network. Untuk lebih jelasnya perhatikan gambar di bawah ini

perhatikan gambar di atas dan catatlah semua url di atas (catat domain nya saja) lalu dapatkan ip address nya dengan menggunakan nslookup

C:\Users\RumahCode.Org>nslookup r5---sn-2a5thxqp5-jb3s.googlevideo.com
Server:  dns.google
Address:  8.8.8.8

Non-authoritative answer:
Name:    r5.sn-2a5thxqp5-jb3s.googlevideo.com
Address:  110.50.80.144
Aliases:  r5---sn-2a5thxqp5-jb3s.googlevideo.com

Sekarang masukan ip di atas dengan menggunakan terminal

/ip firewall address-list
add list=Youtube address=209.85.229.199-209.85.229.204
add list=Youtube address=209.85.229.215-209.85.229.220
add list=Youtube address=209.85.229.231-209.85.229.236
add list=Youtube address=209.85.229.250
add list=Youtube address=209.85.229.151-209.85.229.156

add list=Youtube address=110.50.80.76-110.50.80.83
add list=Youtube address=110.50.80.140-110.50.80.147
add list=Youtube address=110.50.80.204-110.50.80.211
add list=Youtube address=110.50.81.204-110.50.81.211

add list=Youtube address=173.194.4.102-173.194.4.106
add list=Youtube address=173.194.22.70-173.194.22.74
add list=Youtube address=173.194.22.38-173.194.22.42
add list=Youtube address=173.194.22.199-173.194.22.204
add list=Youtube address=173.194.22.215-173.194.22.220
add list=Youtube address=173.194.59.6-173.194.59.10
add list=Youtube address=173.194.147.199-173.194.147.204
add list=Youtube address=173.194.150.167-173.194.150.172

add list=Youtube address=74.125.10.7-74.125.10.12
add list=Youtube address=74.125.10.23-74.125.10.28
add list=Youtube address=74.125.10.55-74.125.10.60
add list=Youtube address=74.125.12.70-74.125.12.74
add list=Youtube address=74.125.12.166-74.125.12.170
add list=Youtube address=74.125.12.198-74.125.12.202
add list=Youtube address=74.125.12.230
add list=Youtube address=74.125.13.70-74.125.13.74
add list=Youtube address=74.125.101.38-74.125.101.42
add list=Youtube address=74.125.101.70-74.125.101.74
add list=Youtube address=74.125.101.198-74.125.101.202
add list=Youtube address=74.125.101.230-74.125.101.234
add list=Youtube address=74.125.164.38-74.125.164.42
add list=Youtube address=74.125.164.70-74.125.164.74
add list=Youtube address=74.125.164.134-74.125.164.138
add list=Youtube address=74.125.171.6-74.125.171.10
add list=Youtube address=74.125.171.70-74.125.171.74

setelah selesai kita biikin rule di raw untuk memblokir ip address yang berada di list Youtube

/ip firewall raw
add action=drop chain=prerouting dst-address-list=Youtube

rule di atas adalah untuk memblokir youtube berdasarkan ip address nya jika kamu membutuhkan ip address youtube untuk keperluan lain silahkan ambil ip address di bawah ini

209.85.229.199-209.85.229.204
209.85.229.215-209.85.229.220
209.85.229.231-209.85.229.236
209.85.229.250
209.85.229.151-209.85.229.156

110.50.80.76-110.50.80.83
110.50.80.140-110.50.80.147
110.50.80.204-110.50.80.211
110.50.81.204-110.50.81.211

173.194.4.102-173.194.4.106
173.194.22.70-173.194.22.74
173.194.22.38-173.194.22.42
173.194.22.199-173.194.22.204
173.194.22.215-173.194.22.220
173.194.59.6-173.194.59.10
173.194.147.199-173.194.147.204
173.194.150.167-173.194.150.172

74.125.10.7-74.125.10.12
74.125.10.23-74.125.10.28
74.125.10.55-74.125.10.60
74.125.12.70-74.125.12.74
74.125.12.166-74.125.12.170
74.125.12.198-74.125.12.202
74.125.12.230
74.125.13.70-74.125.13.74
74.125.101.38-74.125.101.42
74.125.101.70-74.125.101.74
74.125.101.198-74.125.101.202
74.125.101.230-74.125.101.234
74.125.164.38-74.125.164.42
74.125.164.70-74.125.164.74
74.125.164.134-74.125.164.138
74.125.171.6-74.125.171.10
74.125.171.70-74.125.171.74

List di atas adalah list ip address yang menyimpan video video youtube. Jika masih ada yang bisa membuka youtube berarti masih ada ip address youtube yang belum masuk ke list tersebut

Artikel Menarik Lainnya
mikrotik, firewall, linux

loading...